This application is not used any more and exists only for history. Post new tickets on the Github account.
Cette application n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Ticket #1202 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

jMailer: failure when using SingleTo feature and mail() function

Reported by: Julien Owned by: Julien
Priority: high Milestone: Jelix 1.2RC1
Component: jelix:utils Version: trunk
Severity: major Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

I noticed a bug when using SingleTo? feature with mail() function transport in current trunk version (so with updated phpMailer 5.1)

the problem is in class.phpmailer.php at line 648

$params = sprintf("-oi -f %s", $this->Sender);

the error occurs at line 668

$rt = @mail($val, $this->EncodeHeader($this->SecureHeader($this->Subject)), $body, $header, $params);

because $this->Sender may be empty (we're in the "else" block at line 665 where sender is empty or safe_mode does not allow extra params)

In this "else" block, if SingleTo? is false, mail() is called without $params, and works fine.

I suggest removing 5th argument on line 668

patch coming...

I think it must be fixed for jelix 1.2

Change History

comment:1 Changed 4 years ago by Julien

  • Status changed from new to assigned

comment:2 Changed 4 years ago by Julien

  • review set to review?

comment:3 Changed 4 years ago by laurentj

  • review changed from review? to review+

comment:4 Changed 4 years ago by laurentj

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.