This application is not used any more and exists only for history. Post new tickets on the Github account.
Cette application n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Ticket #852 (closed enhancement: fixed)

Opened 5 years ago

Last modified 3 years ago

jacl2db_admin should display the subject more userfriendly

Reported by: foxmask Owned by:
Priority: normal Milestone: Jelix 1.3
Component: module:jacl2db_admin Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

Instead of having acl.group.create in the table of the right we should read "Create Group" which is more userfriendly to understand clearly what is the goal of this right.

thus to do this i propose a little change in attachment.

Attachments

jacl2db_admin_subject_translated.diff (1.5 KB) - added by foxmask 5 years ago.

Change History

Changed 5 years ago by foxmask

comment:1 Changed 5 years ago by foxmask

  • review set to review+

comment:2 Changed 5 years ago by bastnic

  • review changed from review+ to review?

comment:3 Changed 5 years ago by laurentj

  • review changed from review? to review-
$subject = jDao::get('jelix~jacl2subject',$p)->get($rec->id_aclsbj);

very very ugly to do such things into a loop, whereas we could retrieve it with the same..

and no, the id in the array must not be replaced by the subject label, since a label is not always unique

comment:4 Changed 5 years ago by laurentj

sorry, a unfinished sentence : "with the same query"

comment:5 Changed 5 years ago by laurentj

and I think it is better to keep the id in the table (it is important for developers or webmaster). The label should be just an additional description.

comment:6 Changed 5 years ago by foxmask

So, we can not use label_key nor display something like "Create Group" and keep acl.create.group ?

If yes ; i think this ticket can be closed as wontfix/invalid.

On my side i thought "Create Group" était plus parlant than "acl.create.group" for a user that dont understand anything to the terminology of ACL, but could easyly understand what will happen if he checks "Create Group".

comment:7 Changed 5 years ago by laurentj

je vais le faire en français, parce apparemment je me suis mal exprimé. Je n'ai pas dit que c'était impossible, j'ai dit, en résumant, que ton patch fait les choses de façon très très mal (un select dans un select, très beurk, et utiliser le label comme clé dans le tableau php est très mauvais), et qu'il fallait afficher les deux colonnes, id et label.

comment:8 Changed 5 years ago by foxmask

J'ai fait plusieurs essais mais rien ne me plait.

Limite rajouter un foreigntable dans la DAO mais je trouve pas

donc si Surfoo qui avait eu le même besoin que moi veut s'y coller ...

comment:9 Changed 3 years ago by laurentj

  • Status changed from new to confirmed
  • review review- deleted

This feature have been fixed in jelix 1.3.

comment:10 Changed 3 years ago by laurentj

  • Status changed from confirmed to closed
  • Resolution set to fixed
  • Milestone set to Jelix 1.3
Note: See TracTickets for help on using tickets.