developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1013 closed enhancement (duplicate)

jDb: we should support relative path for sqlite databases

Reported by: Julien Owned by: Julien
Priority: normal Milestone: Jelix 1.2 beta
Component: jelix:db Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

When using PDO with SQLite3 driver, we have to provide the path to the database. I suggest allowing the "app:" keyword to have a relative path to the app's path.

Attachments (1)

1013-jDb-sqlite-pdo-relative-path.diff (666 bytes) - added by Julien 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by Julien

comment:1 Changed 11 years ago by Julien

  • Status changed from new to assigned

comment:2 Changed 11 years ago by laurentj

  • Resolution set to duplicate
  • review review? deleted
  • Status changed from assigned to closed

duplicate of #590. see comments on this tickets, and i'm waiting for your comments :-)

comment:3 Changed 11 years ago by Julien

ok continue on #590.

Note: See TracTickets for help on using tickets.