developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 11 years ago

Closed 11 years ago

#1021 closed bug (fixed)

Problème avec php 5.3 et Jelix 1.1.4

Reported by: yamsuz Owned by:
Priority: high Milestone: Jelix 1.1.5
Component: jelix:tpl Version: 1.1.4
Severity: major Keywords:
Cc: Blocked By:
Blocking: #463 Documentation needed: no
Hosting Provider: Php version: 5.3

Description

Je viens de mettre en place en local (sur wamp et php 5.3). Au moment de charger la page pour la première fois (après avoir vidé le répertoire Temp) j'obtiens toujours le message suivant :

Constant T_GOTO already defined ...\lib\jelix\tpl\jTplCompiler.class.php 13

Par contre en rechargeant la page, le message disparait. Je sais pas si c'est un bug ou c'est normal. Je n'avais pas l'erreur dans les versions précédentes

Change History (5)

comment:1 Changed 11 years ago by foxmask

Le message disparait une fois la page en cache.

J'avais le meme probleme avec les NOTICE à propos des fonction dépréciée.

Cependant ce message n'aurait pas dû se produire.

Je pourrai corriger mais pas tester car je ne dispose pas d'une 5.3 sur mon linux.

Donc cela serait mieux si un autre pouvait tester avec la bonne version de PHP :)

comment:2 Changed 11 years ago by foxmask

  • Milestone set to Jelix 1.1.5

comment:3 Changed 11 years ago by laurentj

  • Component changed from jelix to jelix:tpl
  • Priority changed from normal to high
  • Severity changed from normal to major

comment:4 Changed 11 years ago by laurentj

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 11 years ago by laurentj

  • Blocking 463 added
Note: See TracTickets for help on using tickets.