developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 10 years ago

Closed 7 years ago

#1036 closed task (fixed)

sqlite3 driver for jdb

Reported by: laurentj Owned by:
Priority: normal Milestone: Jelix 1.5.0
Component: jelix:plugins:db Version: 1.1.4
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version: 5.3

Description (last modified by laurentj)

sqlite3 is supported in PHP 5.3. we should provide a driver for it.

Change History (7)

comment:1 Changed 10 years ago by laurentj

  • Description modified (diff)
  • Priority changed from high to normal
  • Summary changed from verify if the sqlite api of PHP 5.3 is compatible with our sqlite driver for jdb to sqlite3 driver for jdb

comment:2 Changed 10 years ago by laurentj

  • Milestone changed from Jelix 1.2 to Jelix 2.0

comment:3 Changed 8 years ago by laurentj

  • Status changed from new to confirmed

comment:4 Changed 8 years ago by laurentj

  • Milestone changed from Jelix 2.0 to Jelix 1.5

comment:5 Changed 8 years ago by laurentj

There is an experimental driver into Jelix 1.4, however we don't have a row count method since Sqlite3 doesn't provide an api for that. we should find a solution.

comment:6 Changed 7 years ago by laurentj

  • Blocking 463 removed

(In #463) For Jelix 1.5, we have been done all that was possible without breaking everything.

comment:7 Changed 7 years ago by laurentj

  • Resolution set to fixed
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.