developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 12 years ago

#1102 closed bug (fixed)

jInstaller: installers do not execute

Reported by: Julien Owned by:
Priority: high Milestone: Jelix 1.2 beta
Component: jelix:installer Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

look at this forum thread : http://jelix.org/forums/forum/5-jelix-utilisation-et-developpement/posts/6612-6612-jelix-1-2-pb-avec-les-scripts-d-installation-de-module

To reproduce :

  • build the trunk lib
  • build the trunk testapp
  • configure dbprofiles (use an empty db)
  • php testapp/install/installer.php

install will fail and tables won't be created into the db

block starting at lib/jelix/installer/jInstaller.class.php:479 seems to be the problem : updaters seems to be triggered before the installers.

just replaced that line by

if (false && $flags & self::FLAG_MIGRATION_11X) {

to temporary bypass. Seems to work for initial install (don't know much about this migration flag ?)

Attachments (1)

1102.patch (3.1 KB) - added by laurentj 12 years ago.
wip

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by laurentj

wip

comment:1 Changed 12 years ago by laurentj

  • Milestone changed from Jelix 1.2 to Jelix 1.2 beta
  • Priority changed from normal to high

I think this patch fixes the bug. I didn't test yet.

comment:2 Changed 12 years ago by laurentj

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.