developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 11 years ago

Closed 11 years ago

#1331 closed bug (fixed)

jProfiles and PDO : useless multiple connections

Reported by: Julien Owned by: Julien
Priority: high Milestone: Jelix 1.3 beta 1
Component: jelix:utils Version: trunk
Severity: major Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

it seems that jProfiles stores already created connections incorrectly, and its clearly visible with PDO in the debug bar : lot of queries like 'set names utf8' that are done in the constructor...

I think the problem is general, even without PDO, but is "hidden" when using permanent connections..

here's the patch: https://bitbucket.org/julieni/jelix-trunk-patches/src/128b1c3f30f5/jDb-pdo-multiple-useless-connections.patch

Change History (3)

comment:1 Changed 11 years ago by Julien

  • Owner set to Julien
  • Status changed from new to assigned

comment:2 Changed 11 years ago by laurentj

  • review changed from review? to review+

comment:3 Changed 11 years ago by laurentj

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.