developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1410 closed bug (fixed)

Pb de chargement de classe en ligne de commande avec php 5.3

Reported by: Vincentv Owned by:
Priority: normal Milestone: Jelix 1.1.10
Component: tools:jelix build Version: 1.1.9
Severity: major Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version: 5.3

Description

Bonjour,

Quand on compile les sources de jelix en configurant PHP_VERSION_TARGET = 5.3, le spl_autoload_register du fichier lib/jelix/init.php:215 passe à la trappe à cause du préprocesseur PHP52ORMORE qui est à false.

L'absence de spl_autoload_register pose un problème lors de l'utilisation de la ligne de commande.

Si le support se limite a php 5.2 et php 5.3 on pourrait supprimer cette condition?

Change History (3)

comment:1 Changed 9 years ago by laurentj

  • Milestone set to Jelix 1.2.4

comment:2 Changed 9 years ago by laurentj

  • Milestone changed from Jelix 1.2.4 to Jelix 1.1.10
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 1.2.3 to 1.1.9
Note: See TracTickets for help on using tickets.