developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 9 years ago

Closed 9 years ago

#1427 closed bug (fixed)

jDao generate an invalid query with prefix table

Reported by: foxmask Owned by:
Priority: normal Milestone: Jelix 1.2.6
Component: jelix:dao Version: 1.2.4
Severity: critical Keywords:
Cc: Blocked By:
Blocking: #1403 Documentation needed: no
Hosting Provider: Php version:

Description

This is not a valid query :

invalid query (Unknown column 'prf_usr.usr_login' in 'order clause'(SELECT `usr`.`usr_login` as `login`, `usr`.`usr_email` as `email`, `usr`.`usr_password` as `password` FROM `prf_jlx_user` AS `usr` ORDER BY prf_usr.`usr_login` asc LIMIT 0,20))

the issue is on the ORDER BY ; the table is still an alias ; we should not add the prefix here

Change History (3)

comment:1 Changed 9 years ago by foxmask

c'est bien une regression dans jDaoFactoryBase

ligne 363 il y avait avant :

$order[] = $this->_conn->encloseName($name).' '.$way;

comment:2 Changed 9 years ago by laurentj

  • Blocking 1403 added
  • Component changed from module:jauthdb to jelix:dao
  • Milestone changed from Jelix 1.3 to Jelix 1.2.6
  • Version changed from trunk to 1.2.4

comment:3 Changed 9 years ago by laurentj

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.