developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 13 years ago

Closed 9 years ago

#318 closed new feature (fixed)

Add the support of the mysqli API

Reported by: laurentj Owned by: FlorianLB
Priority: highest Milestone: Jelix 1.4
Component: jelix:db Version: 1.0 beta 3.1
Severity: major Keywords:
Cc: f.lonqueu.brochard+jelix-trac@… Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

A mysqli driver for jDb could be interesting

Change History (10)

comment:1 Changed 13 years ago by laurentj

  • Milestone set to Jelix 1.1
  • Priority changed from normal to low

comment:2 Changed 13 years ago by laurentj

  • Documentation needed unset
  • Milestone changed from Jelix 1.1 beta 1 to Jelix 1.1 beta 2

comment:3 Changed 12 years ago by laurentj

  • Milestone Jelix 1.1 beta 2 deleted

comment:4 Changed 9 years ago by laurentj

  • Priority changed from low to highest
  • Severity changed from normal to major

We should bring support of the mysqli api, since the old mysql api will be deprecated in PHP 5.4

comment:5 Changed 9 years ago by laurentj

  • Milestone set to Jelix 1.4

comment:6 Changed 9 years ago by laurentj

  • Status changed from new to confirmed

comment:7 Changed 9 years ago by FlorianLB

  • Cc f.lonqueu.brochard+jelix-trac@… added

Voici un tout premier brouillon : https://github.com/FlorianLB/jelix/commit/3fb40c5fe7d5bb7856646ab9ae415565c8122dcb

J'ai besoin de votre avis général mais surtout sur :

  • la gestion des transactions

Et pour les tests unitaires, il y a un système complet pour chaque driver fait avec SimpleTest?, je le fais avec ou j'utilise PHPUnit ?

J'ai changé uniquement DbResultSet? et DbConnection?, me semble pas qu'il y ait grand chose à changer dans le reste.

comment:8 Changed 9 years ago by laurentj

  • Owner set to FlorianLB
  • Status changed from confirmed to assigned

J'ai fait des commentaires dans le commit ;-)

Pour bindParam, je ne sais pas, je n'ai pas regardé ça.

Pour la gestion des transactions, c'est quoi la question ? ça me parait bien ce que tu as fait.

Pour les tests, utilise le système existant. Sauf si tu as du temps pour migrer le strict nécessaire pour les tests pour mysqli (on migrera pour pgsql etc plus tard). Il faudra bien le faire un jour ou l'autre de toute façon.

comment:9 Changed 9 years ago by FlorianLB

J'ai répondu dans le commit et j'en ai push un nouveau avec les corrections et les tests unitaires qui passent tous sans soucis.

comment:10 Changed 9 years ago by laurentj

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.