developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 8 years ago

#463 closed task (fixed)

Support of PHP 5.3

Reported by: laurentj Owned by:
Priority: high Milestone: Jelix 1.5.0
Component: jelix Version:
Severity: normal Keywords:
Cc: Blocked By: #797, #985, #1021, #1029, #1030, #1031, #1032, #1035, #1038, #1039, #1053, #1475
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description (last modified by laurentj)

Ticket to track enhancements which can be made for PHP 5.3. See the list of tickets which block this ticket.

Please create a new ticket for bugs or enhancement to do, about the support of PHP 5.3, and block this one.

Change History (29)

comment:1 Changed 12 years ago by laurentj

  • use of late static binding ? (static::func())
  • use of static() magic method ?
  • support of E_DEPRECATED, and E_ALL includes E_STATIC now
  • improvements of the support of ini files.

comment:2 Changed 12 years ago by laurentj

  • Documentation needed unset
  • Version 1.0.2 deleted

comment:3 follow-up: Changed 11 years ago by foxmask

Some doc about this topics :

deprecated function use in Jelix; are concerned :

use split, preg_split should be used instead :

  • jelix\core\jConfigCompiler
  • jelix\core\response\jResponseXmlFeed
  • jelix\forms\jFormsCompiler_if_1_0
  • jelix-scripts\modules\beta_migration\controllers\default.cmdline
  • phpMailer\class.phpmailer.php
  • simpletest\url.php

use ereg, preg_match should be used instead :

  • phpMailer\class.phpmailer.php
  • tcpdf\tcpdf.php

comment:5 Changed 11 years ago by foxmask

PHP 5.3 n'aime pas les locales du genre "foo.goto.bar" et rale sur goto interdit ici.

comment:6 Changed 11 years ago by laurentj

Replaced deprecated functions, replaced braces by square brackets in instruction which get characters of string, and support of the "goto" keyword in locales name in templates.

For trunk:

For 1.1.x:

No support in 1.0.x since it is a too old branch.

comment:7 Changed 11 years ago by yamsuz

  • Type changed from task to bug
  • Version set to 1.1.4

Je viens de mettre en place en local (sur wamp et php 5.3). Au moment de charger la page pour la première fois (après avoir vidé le répertoire Temp) j'obtiens toujours le message suivant :

Constant T_GOTO already defined [...]\lib\jelix\tpl\jTplCompiler.class.php 13

Par contre en rechargeant la page, le message disparait. Je sais pas si c'est un bug ou c'est normal. Je n'avais pas l'erreur dans les versions précédentes

comment:8 Changed 11 years ago by laurentj

  • Milestone set to Jelix 2.0
  • Type changed from bug to task
  • Version 1.1.4 deleted

merci de créer un ticket pour les bugs relatifs à php 5.3, pas de modifier ce ticket pour chaque bug trouvé.

comment:9 Changed 11 years ago by laurentj

  • Blocked By 797, 985, 1021 added
  • Priority changed from normal to high
  • Severity changed from minor to normal

comment:10 Changed 11 years ago by laurentj

  • Blocked By 1029 added

comment:11 Changed 11 years ago by laurentj

  • Blocked By 1030 added

comment:12 Changed 11 years ago by laurentj

  • Blocked By 1031 added

comment:13 Changed 11 years ago by laurentj

  • Description modified (diff)

comment:14 Changed 11 years ago by laurentj

  • Blocked By 1032 added

comment:15 Changed 11 years ago by laurentj

  • Blocked By 1033 added

comment:16 Changed 11 years ago by laurentj

  • Blocked By 1034 added

comment:17 Changed 11 years ago by laurentj

  • Blocked By 1035 added

comment:18 Changed 11 years ago by laurentj

  • Blocked By 1036 added

comment:19 Changed 11 years ago by laurentj

  • Blocked By 1037 added

comment:20 Changed 11 years ago by laurentj

  • Blocked By 1038 added

comment:21 Changed 11 years ago by laurentj

  • Blocked By 1039 added

comment:22 Changed 10 years ago by mike

  • Blocked By 1053 added

comment:23 in reply to: ↑ 3 Changed 10 years ago by mike

Replying to foxmask:

...

use split, preg_split should be used instead : ...

  • phpMailer\class.phpmailer.php

will be corrected when #1053 is done

comment:24 Changed 9 years ago by laurentj

  • Status changed from new to confirmed

comment:25 Changed 8 years ago by laurentj

  • Milestone changed from Jelix 2.0 to Jelix 1.5

comment:26 Changed 8 years ago by laurentj

  • Blocked By 1475 added

comment:28 Changed 8 years ago by laurentj

  • Blocked By 1033, 1034, 1036, 1037 removed

For Jelix 1.5, we have been done all that was possible without breaking everything.

comment:29 Changed 8 years ago by laurentj

  • Resolution set to fixed
  • Status changed from confirmed to closed
Note: See TracTickets for help on using tickets.