developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 12 years ago

#574 closed new feature (invalid)

Nouveau plugin de template modifier.escape

Reported by: sylvain261 Owned by:
Priority: normal Milestone:
Component: jelix:plugins Version: 1.0.3
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

Portage pour jtpl du modifier escape de smarty template engine

Attachments (1)

modifier.escape.patch (2.8 KB) - added by sylvain261 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by sylvain261

comment:1 Changed 12 years ago by sylvain261

  • review set to review?

comment:2 Changed 12 years ago by laurentj

  • review review? deleted

cette fonction fait doublon avec un modificateur existant (eschtml/escxml). Pour le support de htmlentites, c'est un peu hasbeen. Si je n'ai pas porté ce modificateur à l'origine, c'est parce que je n'aime pas trop ces fonctions qui font tout en plus du café. Ex: Pour "echapper" une url, pourquoi "inventer" ce modificateur, alors qu'il serait mieux de faire un modificateur "urlencode" : plus simple et plus intuitif à utiliser.

comment:3 Changed 12 years ago by bballizlife

What about this ticket ? I'm ok this plugin is a duplicate of the eschtml/escxml ones.

So here is there anything to add ? Does the escape plugin provide something more than existing ones ?

I suggest that if it can improve them, let's make a proposal, else we will close the ticket.

comment:4 Changed 12 years ago by sylvain261

ok to close

comment:5 Changed 12 years ago by bballizlife

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.