developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 12 years ago

#605 closed bug (fixed)

jelix tpl and locale : {@module~toto.eval.titi@} raises an exception

Reported by: bibo Owned by: laurentj
Priority: low Milestone: Jelix 1.0.5
Component: jelix:tpl Version: 1.0.3
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

the exception raised is :

[exception 307] Dans le tag @module~toto.eval.criteria@ of template some.tpl, php eval is not authorized

if i am using {jlocale 'module~toto.eval.titi'}, no exception.

PS : i am using trunk.

Change History (3)

comment:1 Changed 12 years ago by bibo

I forgot the most important: noticed the keyword eval in the locale. that's the cause of this burden of course.

comment:2 Changed 12 years ago by laurentj

  • Component changed from jelix to jelix:tpl
  • Milestone set to Jelix 1.0.4
  • Owner set to laurentj
  • Status changed from new to assigned

comment:3 Changed 12 years ago by laurentj

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in the trunk and 1.0.x branch

Note: See TracTickets for help on using tickets.