developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#784 closed enhancement (fixed)

jForms: help messages should work without javascript

Reported by: Julien Owned by: Julien
Priority: normal Milestone: Jelix 1.2 beta
Component: jelix:forms Version: 1.0RC1
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

we could use a nice icon, with some kind of CSS tooltip.

The javascript thing will remain, but I would prefer not to output things like this in the default builders :

<span class="jforms-help">
    <a href="javascript:jFormsJQ.showHelp('jforms_users_profile','password_confirm')">?</a>
</span>

Attachments (2)

784-jForms-help-messages-should-work-without-javascript.diff (2.8 KB) - added by Julien 12 years ago.
help.png (786 bytes) - added by Julien 12 years ago.
help icon from FamFamFam? Silk

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Julien

  • Status changed from new to assigned

Changed 12 years ago by Julien

help icon from FamFamFam? Silk

comment:2 Changed 12 years ago by Julien

  • Milestone changed from Jelix 1.2 to Jelix 1.1.1
  • review set to review?

should we care about IE < 7 which doesn't handle :hover except on links ?

comment:3 Changed 12 years ago by laurentj

  • Milestone changed from Jelix 1.1.1 to Jelix 1.2

The javascript thing will remain,

the problem is that script won't work anymore, since they won't be called anymore.

Perhaps we should to think about a new API in the javascript, and have a best use of jQuery...

However, this change won't be for 1.1.1 since it breaks the behavior. At least for 1.2.

comment:4 Changed 11 years ago by laurentj

I think we will kill the support of this jFormsHelpDecorator object. Users on #jelix want a span and no more js.

comment:5 Changed 11 years ago by laurentj

  • Documentation needed set
  • Resolution set to fixed
  • review changed from review? to review+
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.