developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 12 years ago

Closed 12 years ago

#801 closed bug (duplicate)

The behavior of jFilter::isIPv4 and jFilter::isIPv6 is not exactly the same

Reported by: doubleface Owned by:
Priority: low Milestone: Jelix 1.0.8
Component: jelix:utils Version: trunk
Severity: trivial Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

When PHP filter is deactivated, jFIlter::isIPv4 returns true (if we have an ip address) and jFilter::isIPv6 returns 1 (preg_match return value).

I think this should be exactly the same, don't you think?

Here is a patch for this.

Attachments (5)

jfilter.patch (542 bytes) - added by doubleface 12 years ago.
jfilter.2.patch (542 bytes) - added by doubleface 12 years ago.
jfilter.3.patch (542 bytes) - added by doubleface 12 years ago.
jfilter.4.patch (542 bytes) - added by doubleface 12 years ago.
jfilter.5.patch (2.1 KB) - added by doubleface 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by doubleface

Changed 12 years ago by doubleface

Changed 12 years ago by doubleface

Changed 12 years ago by doubleface

Changed 12 years ago by doubleface

comment:1 Changed 12 years ago by doubleface

There is exactly the same problem with jFilter::isEmail. The patch is updated (jfilter.5.patch) sorry for the other multiple updates...

comment:2 Changed 12 years ago by laurentj

  • Component changed from jelix to jelix:utils
  • Milestone set to Jelix 1.0.8
  • review changed from review? to review+

It should be landed into the 1.0.x branch, 1.1.x branch and in the trunk.

comment:3 Changed 12 years ago by laurentj

  • Resolution set to duplicate
  • Status changed from new to closed

#842 is a duplicate of this ticket and patch of 842 has been landed.

Note: See TracTickets for help on using tickets.