developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#842 closed bug (fixed)

jFilter does not return the same value if php filter is activated or not

Reported by: doubleface Owned by: doubleface
Priority: normal Milestone: Jelix 1.0.8
Component: jelix:utils Version: 1.1
Severity: trivial Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

We have this problem for isIPv6 and isEmail methods of jFilter. They return an int when php filter is used and a boolean when it is not used.

See the patch

Attachments (1)

jfilter.patch (2.1 KB) - added by doubleface 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by doubleface

comment:1 Changed 10 years ago by laurentj

  • Milestone set to Jelix 1.0.8
  • review changed from review? to review+

ok. thanks.

should be landed into 1.0.x, 1.1.x, and trunk

comment:2 Changed 10 years ago by laurentj

update also the CREDITS file

comment:3 Changed 10 years ago by doubleface

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [1326]

comment:4 Changed 10 years ago by laurentj

  • Resolution fixed deleted
  • Status changed from closed to reopened

not landed in 1.0.x and 1.1.x

comment:5 Changed 10 years ago by doubleface

  • Resolution set to fixed
  • Status changed from reopened to closed

Also fixed in [1327] and [1328]

comment:6 Changed 10 years ago by laurentj

sorry, i didn't see other revisions.

note that this ticket is a duplicate of #801

Note: See TracTickets for help on using tickets.