developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 10 years ago

Closed 9 years ago

#877 closed bug (fixed)

Bad path in Jelix script with JELIX_APP_TEMP_PATH

Reported by: jeremie.walter Owned by: bballizlife
Priority: normal Milestone: Jelix 1.1.3
Component: jelix-scripts Version: 1.1
Severity: normal Keywords: script jelix-script
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

Sorry if my english is not very good, i'm french and i try to post in english :)

When I try to create a new app or a new module with the jelix script method, I have this error message : Error: bad path in JELIX_APP_TEMP_PATH, it is equals to '/' !! Jelix cannot clear the content of the temp directory. Correct the path in JELIX_APP_TEMP_PATH or create the directory you indicated into JELIX_APP_TEMP_PATH.

Maybe it coul'd be a problem relative to this recent fix (Tickets #840) because when I modify jelix.php,

OLD : define ('JELIX_APP_TEMP_PATH',    substr(JELIXS_APPTPL_TEMP_PATH,0,-1).'-jelix-scripts/');
NEW : define ('JELIX_APP_TEMP_PATH',    substr(JELIXS_APPTPL_TEMP_PATH,0,-1));

the problem disapear.

What can we do for resolving the two problems.

Change History (8)

comment:1 Changed 10 years ago by laurentj

Your fix is VERY bad. Because the result is this temp directory is shared by the web application AND by jelix-scripts. You can have problems with rights (especially if you are on an unix machine).

The problem is not in jelix.php, but in your jelix-scripts.init.php. You should fix this file. In fact, perhaps createapp didn't create the temp directory for jelix-scripts. isn't it ?

Which version are you running ? 1.1 or 1.1.1 ? With which version did you create your application ?

comment:2 Changed 10 years ago by jeremie.walter

I use the 1.1.1 dev version downloaded here : http://jelix.org/articles/fr/telechargement/stable/1.1

Yes, createapp didn't create the temp directory for jelix-script. This is why I have the error message. How can I fix this ?

P.S : I use an alias to execute the jelix script so I can type 'jelix' everywhere, it will run. For this case, I execute them at the following folder : '/opt/jelix'. Maybe my error come for this operation ?

comment:3 Changed 10 years ago by laurentj

  • Milestone set to Jelix 1.1.2

How can I fix this ?

well, we should fix the createapp command.

I use an alias to execute the jelix script so I can type 'jelix' everywhere

a better solution is to modify your PATH environment variable. A "jelix" shell script is already provided in jelix-script

comment:4 follow-up: Changed 9 years ago by bballizlife

I can't reproduce with 1.1.2. Does the problem still exists for you ?

comment:5 in reply to: ↑ 4 Changed 9 years ago by jeremie.walter

Replying to bballizlife:

I can't reproduce with 1.1.2. Does the problem still exists for you ?

Maybe the problem was fixed with 1.1.2.

I'll try it.

comment:6 Changed 9 years ago by bballizlife

  • Owner set to bballizlife
  • Status changed from new to assigned

Ok thanks. I'll be waiting for your feedback. If you still have the problem, please let me know a use case so i could reproduce it (and so fix it ;)).

comment:7 follow-up: Changed 9 years ago by bballizlife

@jeremie.walter : Could you please tell us if you still have the bug ? Thank you.

comment:8 in reply to: ↑ 7 Changed 9 years ago by jeremie.walter

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to bballizlife:

@jeremie.walter : Could you please tell us if you still have the bug ? Thank you.

Hello,

Sorry for the late response but I have a lot of work at office.

I test with the 1.1.2 version and I can't reproduce the problem. I think the probkem was fix with 1.1.2 version.

Thank you for the time taken to developp jelix and improve it !

Note: See TracTickets for help on using tickets.