developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 10 years ago

Closed 9 years ago

#883 closed bug (wontfix)

impossible to have a different urlengine for each entry points of a same application

Reported by: foxmask Owned by: laurentj
Priority: normal Milestone:
Component: jelix:core Version: 1.1.1
Severity: minor Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

In my defaultconfig.ini.php i put

[urlengine]
engine=simple

I have 2 entries point :

index.php admin.php

the config.ini.php of the first contains :

[urlengine]
engine=significant

in the second config.ini.php i have :

[urlengine]
engine=simple

The goal is to have significant URL on the "public" part of the site and simple URL in the "admin" part.

But unfortunalty the signficant engine takes precedence on all others ones.

If i use basic_significant as engine for "index.php" entry point, then the engine of "admin.php" is use correclty as "simple".

Change History (4)

comment:1 follow-up: Changed 10 years ago by laurentj

  • Component changed from jelix to jelix:core
  • Owner set to laurentj
  • Severity changed from major to minor

But unfortunalty the signficant engine takes precedence on all others ones.

wrong. the problem is just that it is the current engine which is used.

However, for me, this bug is invalid because in fact here you have two applications. And then you cannot call jUrl to generate an url of an other application. If for you these aren't different application, so you have to use the same url engine. this is obvious for me.

If we really want to fix this bug, it is needed to rewrite the url engine architecture.

comment:2 Changed 10 years ago by laurentj

  • Summary changed from urlengine not used correctlty to impossible to have a different urlengine for each entry points of a same application

comment:3 in reply to: ↑ 1 Changed 10 years ago by foxmask

Bonsoir,

Replying to laurentj:

But unfortunalty the signficant engine takes precedence on all others ones.

wrong. the problem is just that it is the current engine which is used.

pour la faire un français et eviter une incomprehension : si c'était le cas ; comme se fait-il que si on utilise comme moteur pour l'entry point "index.php", "basic_significant" et "simple" pour "admin.php", cela ne pose psa de problème ?

However, for me, this bug is invalid because in fact here you have two applications.

non c'est une appli (un forum) avec 2 entry point un pour le frontoffice un pour le backoffice

And then you cannot call jUrl to generate an url of an other application. If for you these aren't different application, so you have to use the same url engine. this is obvious for me.

ok donc fermons ce bug, je passerai tout sous le même moteur d'url, c'est un peu longuet avec le significant engine, mais pas injouable.

If we really want to fix this bug, it is needed to rewrite the url engine architecture.

je ne m'y aventurerai pas ;)

cdt.

comment:4 Changed 9 years ago by laurentj

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.