developer.jelix.org is not used any more and exists only for history. Post new tickets on the Github account.
developer.jelix.org n'est plus utilisée, et existe uniquement pour son historique. Postez les nouveaux tickets sur le compte github.

Opened 11 years ago

Closed 11 years ago

#957 closed bug (fixed)

Problems in jReponseRedirect

Reported by: afroxav Owned by: afroxav
Priority: lowest Milestone: Jelix 1.0.11
Component: jelix:core response Version: trunk
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Documentation needed: no
Hosting Provider: Php version:

Description

There are few problems in jResponseRedirect that need to be corrected.

First of all, there is a missing ?> at the end of the document. Second, the location header should start by a capital letter Thirdly, the name of the headers is not set correctly.

I will submit the patch myself.

Attachments (1)

957.diff (1.4 KB) - added by afroxav 11 years ago.
Patch for trunk

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by laurentj

  • Priority changed from high to lowest
  • Severity changed from critical to normal

there is a missing ?> at the end of the document.

this is not a problem. And it's more secure to avoid errors on headers... WONTFIX.

the location header should start by a capital letter

the specification ( http://www.w3.org/Protocols/rfc2616/rfc2616-sec4.html#sec4.2 ) says : Field names are case-insensitive. So, location equals to Location. WONTFIX

the name of the headers is not set correctly.

What is the problem exactly ?

Changed 11 years ago by afroxav

Patch for trunk

comment:2 Changed 11 years ago by afroxav

Some browsers do not recognize the location header but recognize the Location header

The name of the 301 header is not redirection but Moved Permanently, and the name of the 303 header is See Other.

I can modify my diff file.

comment:3 Changed 11 years ago by laurentj

Some browsers do not recognize the location header but recognize the Location header

which one ?

The name of the 301 header is not redirection but Moved Permanently, and the name of the 303 header is See Other.

Ok. However, note this is not a bug, since this is just an information. see http://www.w3.org/Protocols/rfc2616/rfc2616-sec6.html#sec6.1.1 : "The client is not required to examine or display the Reason-Phrase"

comment:4 Changed 11 years ago by laurentj

One thing we can fix, is the url of the location : apparetly, it should be an absolute URI, with scheme, domain etc...

comment:5 Changed 11 years ago by laurentj

Ok, apparently, IE7 doesn't support "location"... http://fr.php.net/manual/en/function.header.php#79028

comment:6 Changed 11 years ago by laurentj

  • Milestone changed from Jelix 1.1.4 to Jelix 1.0.11

comment:7 Changed 11 years ago by afroxav

  • Status changed from new to assigned

Do you want me to modify my diff file?

comment:8 Changed 11 years ago by laurentj

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.